HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
dicko450

Starter motor issues

1 post in this topic

Hey guys, got an issue with the e-start on my 08 wr450. Had the carb out doing some re-jetting and when I reassembled everything the e-start wouldn't work, just clicking noise from the relay. Thought the battery must have lost it's mojo as it's got a few years on it and it's been sitting for awhile so bought a new battery but still no go, checked wiring and all seems good so took starter motor off and it seems seized i.e. can't spin the drive gear at all. I took the starter apart but there's a circlip holding the front cover on which I can't get at, can anyone tell me if there's a bearing in there that might be seized or if anyone has experienced this problem before ? Cheers.

Edited by dicko450

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0