WR400F Carb venting?

Its a 2000 model. The bike runs fine and strong. i recently cleaned out the carb. what seems to be happening here is that the carb is vapor locked or not venting. Fuel is not refilling the supply line. The petcock is brand new and flows fine. I shot some low pressure air through the fuel line and it blew out of the vent lines. yesterday was the first day that i was able to get out and ride it, and when my issue occurred on the trail i would have to pull the fuel line off the petcock and slowly turn the fuel on and fill the line back up to get myself back to civilization. Any thoughts on what this could be? Thanks in advance.

Sounds like your fuel tank cap vent is blocked. Creating a vacuum as the fuel level drops.

Try loosening your fuel cap to test it.

the gas cap was one of the first things i tried. I pulled the cap off and still do not get any flow from the petcock to the carb.

Your float / needle valve could be sticking.

Try dropping the bowl and see if the floats are moving freely.Then turn on fuel and see if it flows out of the carb with the bowl off.

Your float / needle valve could be sticking.

Try dropping the bowl and see if the floats are moving freely.Then turn on fuel and see if it flows out of the carb with the bowl off.

Instead of pulling the entire bowl off I started with the drain plug. I pulled that and turned the fuel cock on and she poured fuel. I still don't understand what's going on. I can't start it at the moment to test it out. My radiators got busted up pretty bad last weekend. Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now