07 WRF... retard cam, hotcam, or yz450f cam?

_MG_9231.JPG

My buddy Steve. He rides that DRZ like it's a trials bike

%255BUNSET%255D.jpg

%255BUNSET%255D.jpg

Edited by n16ht5

I didnt see in the link where it said anything about grinding down the decomp pin. Maybe I missed it but does this need to

be done to all WR's ?

I am seriously thinking about doing this.

Yeah the yzf450 quad doesn't need the decomp pin ground down (that link) but on our WRs they do. Get a dremel and a sandpaper wheel and go to town.. then some 220 and a few sets finer of sandpaper to polish it up afterward like my pics.

Where did you come up with the idea to grind the pin? Also how did you figure 1mm would be enough or not enough? Do you have any more info on this?

How did this effect mpg?

Where did you come up with the idea to grind the pin? Also how did you figure 1mm would be enough or not enough? Do you have any more info on this?

How did this effect mpg?

Dont worry about it.. just do the mod! Mpg? Probably helped but who cares when you got all that krunk on tap

Dont worry about it.. just do the mod! Mpg? Probably helped but who cares when you got all that krunk on tap

This is the first I've read on grinding the pin so I do worry. And MPGs 100+ mile between gas stops makes me care.

Wait....you mean you didn't have any birds eating out of your hand on this ride????

LOL

lol naw, that was last weekend with my wife and daughter :goofy: she's a bit too small to dirt bike yet, butsoon!

Edited by n16ht5

This is the first I've read on grinding the pin so I do worry. And MPGs 100+ mile between gas stops makes me care.

from the 250f forum

http://www.thumperta...m-nipple-grind/

Guessing gas mileage stayed the same.. hard to say since I have been riding half street half gnar singletrack. definitely didn't go down noticeably.

Edited by n16ht5

Are you running the YZ silencer in this vid?

Your bike sounds pretty quiet

I think you have some of the best riding where you live. Or your pictures make it seem that way

I know this is an old thread but you guys seem to know your way around these bikes. I had the both the intake and the exhaust Hotcams put in my '07 WR450. The ones designed for the 450:

4023 - 1In

4044 - 1E

The exhaust cam is not supposed to screw wit the e-start performance. I had a shop do the work. Well, the e-start most of the time will just chug, then pause, then chug, then pause, then chug...and hen I will let off the button. I will hit it again and it will eventually start.

In talking to the shop, he says the timing was double checked. The exhaust markings were at 9 and 12 and the intake markings were at 12 and 3 so the timing is right on.

Any ideas as to why the e-start is struggling? I have a new Shorai battery that checks in at 13.87.

Did you call hotcams? Sounds like too much lift/bad timing on the auto decomp pin. Mine still runs like a champ.

Did you call hotcams? Sounds like too much lift/bad timing on the auto decomp pin. Mine still runs like a champ.

So you have no issues with the e-start? Does it turn over just like it did with the stock cams? The bike runs great, it just doesn't like the e-start. I did go up ever so slightly in the piston. 12:3 to a 12:5 with a clean-up port job.

I haven't had been able to do much research into this but...I have YZ cams in my '07Wr450 and it doesn't start with the E-start, will this help with that? I thought switching to Hot Cams was supposed to fix the issue but sounds like not necessarily true.

I haven't had been able to do much research into this but...I have YZ cams in my '07Wr450 and it doesn't start with the E-start, will this help with that? I thought switching to Hot Cams was supposed to fix the issue but sounds like not necessarily true.

Well, it's supposed to. The WR exhaust cam you get from Hotcams has the same lob profile as the YZ exhaust cam it's just that the decmp pin is shorter which is supposed to allow it to work with the e-start.

I spoke with Hotcams today and they said that I should recheck the valve clearance. He said that the valve clearance should be adjusted to a different spec than stock with their cams. Well, I found this to be untrue. Stock exhaust valve clearance is supposed to be between .20-.25 Hotcams says theirs is .20 seems the same to me. Stock intake is .10-.15 Hotcams says theirs is .15 again, seems the same.

I did go from a 12.3:1 to a 12.5:1 compression piston, would that small of a jump make a such a difference as to not allow the starter (which is new along with a new Shorai battery) to crank the motor??

Yeah it actually starts better than it was stock... I would suggest opening it up and putting back in your stock WR cam to see what happens. If it fires right up you know it is the hotcam.

Yeah it actually starts better than it was stock... I would suggest opening it up and putting back in your stock WR cam to see what happens. If it fires right up you know it is the hotcam.

Yeah, thanks, that's prolly what needs to happen. I didnt do the work so I will have to take it back down to the shop. The more I have read about it the more comfortable I am with trying it on my own. But, since I already paid someone to do it..

its never too late to learn... watch some youtube videos or rockymountain videos, they show a lot of good info.

Here is a picture of the 2 cams next to each other. The stock cam is on the left and the hotcam is on the right. Shouldn't the pins be the same length?

IMG_0014.jpg

Edited by kenshaw720

Hmmmm, one millimeter you say ?

IMG4450_zps395d3200.jpg

finally got it all back together. It runs like a raped ape! I just took it for a quick spin down the driveway a few times, dark and raining out.. but it runs better than I was expecting... much more snap right off the bottom. I need to re-jet the carb now.Also, the E start works better than before! It doesn't seem to hang on the compression stroke as much now. Best free mod so far.pics:-starting... %5BUNSET%5D.jpgvalves have moved... probably not a great thing, but the bike has 150+ hard hours and this is the first time they needed to be adjusted%5BUNSET%5D.jpgexhaust cam decomp pin%5BUNSET%5D.jpg%5BUNSET%5D.jpgpin out it measures .940%5BUNSET%5D.jpgdremeled down .040 or 1mm.. then rounded and sanded smooth with a few grades of sandpaper to a shine.%5BUNSET%5D.jpg%5BUNSET%5D.jpgback together, greasing bolts (swingarm bolt) if you haven't ever greased yours, do it. there are pics on the xr400 section of a guy who resorted to cutting off his entire swingarm from a frozen bolt.%5BUNSET%5D.jpgnot even a full season on this skid plate.. call that a good year :)%5BUNSET%5D.jpgnow my lights and accessories only come on with my ignition too :) (relayed the wiring harness)%5BUNSET%5D.jpg

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now