Sign in to follow this  
Followers 0
Lumberjack450

2012 WR450 top end noise?

8 posts in this topic

Heard a noise, like a Rattle, coming from valve train area it sounds like... still starts fine, runs great, but has that noise. Gets louder with the RPMs ...

Only 30 hours on the bike, like 1000 miles of desert... 3hr oil changes, oil filter every other change, cleaned air filter often...

No trouble before this. Came out of nowhere. Only thing I did to the bike between rides was install a scotts stabilizer ..

Any advice or ideas? Going to contact dealer tomorrow. Only 30 hours! :'(

Share this post


Link to post
Share on other sites

Sounds like the plastic spill tray on the fuel tank , I think I'm going to glue mine down. It's funny once I found out what it was, I don't really notice it anymore. But I still might glue it down anyway.

1 person likes this

Share this post


Link to post
Share on other sites

Sounds like the plastic spill tray on the fuel tank , I think I'm going to glue mine down. It's funny once I found out what it was, I don't really notice it anymore. But I still might glue it down anyway.

Is that what they are calling that thing, a Spill tray?????

Share this post


Link to post
Share on other sites

3hr oil changes

How exactly do you do that? Do you never go on more than a three hour ride, or do you change it durring lunch on the trail?

Share this post


Link to post
Share on other sites

How exactly do you do that? Do you never go on more than a three hour ride, or do you change it durring lunch on the trail?

3-4 hours, I live on the edge of my riding area so I just ride an hour or two at a time whenever I can. Obviously if I take it on a trip I ride more before I can change it.. I get free oil so no big deal, I want this thing to last.

I have a desert tank, so no it's not that plastic piece. Plus it's way louder than that..

Taking it in to the shop when I get back from Mexico this weekend, hoping the cam chain or valves just need to be tightened. We'll see.

Share this post


Link to post
Share on other sites

Not sure if your doing the routine maintenance or not but at 600 miles it was time for a valve check. Might be something to look at.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0