WR 426 Loud Intermittent Rattle From Right Side

Well guys, I'm just frustrated beyond belief at this point. I obviously don't know how to work on this bike. It is stuck in gear and the shift lever will not budge. I don't know what I'm doing wrong. I followed the manual and thought everything went well. Any suggestions?

The good news is that the idle is buttery smooth, and the rattle is gone, so I guess it's a start.

-Alex

EDIT: I'm an idiot. I took the clutch off to take a peak and as I expected, the shift shaft arm was not over the little pin, but beside it. It must have wiggled it's way loose when I had the side cover off. Time to drain the fluids and pull the cover off again. This sure has been a learning experience for me, and on the brighter side of things I'm getting really good at changing oil, coolant, clutch plates, and pulling that side cover off. :bonk:

Edited by nnamssorxela

I just got back from a short ride. I'd like to thank everyone for their help and putting up with my incessant questions and thinking out loud. The bike is much quieter (no rattling!) and I finally have some peace of mind, at least until the next issue pops up.

Thanks again and happy riding :ride:

-Alex

Hang in there Alex! We all started out as newbie mechanics at one time! Glad to hear you've got it working well. :thumbsup:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now