HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
R_Little

DSP exhaust

3 posts in this topic

Does anyone have any experience w' the DSP factory series exhaust for the 426?

I'm thinking of buying one but I'm concerned about the noise. Can anyone tell me how it compares to a stock YZF pipe?

Thanks

Share this post


Link to post
Share on other sites

I've got their Ti full system. I have never heard a stock YZ, but mine is loud. It got much better after I repacked it, but it's still loud.

Lukejt

Share this post


Link to post
Share on other sites

I run a DSP w/stainless steel header on my 2000 WR400. It is loud. I have considered getting a different system due to the noise. Also, you will likely need to rejet - I cannot seem to get rid of a dead spot at 1/2 throttle. Did I mention that it was loud?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0