Sign in to follow this  
Followers 0
redswr

99 WR400 questions...

5 posts in this topic

Hey guys i bet you don't remember but i had a build thread over a year ago, well i finally got it all the way together but it's leaking fluids. On the left side where the oil line goes down the frame theres some sort of vent (little 90* elbow) What is that for? Is there a line supposed to come from there and go somewhere? I looked and the top of the valve cover has a hose missing too but i don't think they connect... i can get pics if ya need them. Heres the bike before and after :)

DSCF0285.jpg

IMG176.jpg

Edited by redswr

Share this post


Link to post
Share on other sites

The valve cover hose doesn't connect to anything, just as you suspected. It just vents to outside air, down near the shifting lever. As for the other one, I guess I'm going to need a pic, because I can't figure out where it is from my memory.

Maniac

Share this post


Link to post
Share on other sites

Yes, those two spigots connect together with a short hose.

Maniac

1 person likes this

Share this post


Link to post
Share on other sites

Yes, those two spigots connect together with a short hose.

Maniac

nice i'll see if i got one laying around :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0