HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
ecookman

leaky wr450 rad weer :(

4 posts in this topic

A while ago I replaced the seals in the water pump because coolant was pissing out of the weer hole even when the bike was hot...and after 2 hours of work and a forced oil change, with 5 hours of riding afterwards....still does this.....any Ideas?

1 person likes this

Share this post


Link to post
Share on other sites

Quite often, the water pump shaft itself will develop grooves in it, and will need to be replaced. Did you check the shaft for wear?

Maniac

Share this post


Link to post
Share on other sites

Just an off hand question could you have pinched the seal when you reinstalled? I did. :ride: I also had a "forced oil change". :devil: The next time I laid the bike on it's side to save the one hour old oil change. :banghead:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0