HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Bigdong

09 450 Knocking noise sometimes

8 posts in this topic

I keep getting a loud knocking noise every now and then when im racing from the front of the bike/engine area that i cant seem to pinpoint, I cant get it to do it when its ticking over and only seems to be when im in a higher gear and the engine is straining slightly with the torque. Ive checked everything on the outside of the bike but cant find anything loose. Its about the second hour on a new piston.

The knock is a solid knock but im finding it hard to locate since it only rears its head when im driving at certain times.

Has anyone else had a similar problem or any ideas on what could cause this?So far im pretty convinced its the big end but dont want to split cases yet since ive only been out twice on it :cry:

Edited by Bigdong

Share this post


Link to post
Share on other sites

Could be a hot ping, your valves, piston slap, could be your crank bearings..

Share this post


Link to post
Share on other sites

Check to see if your nut that screws to the crank is loose on the clutch side ( I forget what it is called). This same stuff happened to me before and that was the problem.

Share this post


Link to post
Share on other sites

Took flywheeel cover off and sound is a definate knocking when pulling flywheel from side to side, theres no up and down movement so im hoping bearings are good.

Share this post


Link to post
Share on other sites

Took flywheeel cover off and sound is a definate knocking when pulling flywheel from side to side, theres no up and down movement so im hoping bearings are good.

Anyone know if yz s make this clunk noise normally when pulling at the flywheel?

Share this post


Link to post
Share on other sites

Yes, it's normal. It's the axial play in the right side main bearing that you're seeing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0