HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
proamature

Gets really hot really fast

12 posts in this topic

My bike gets abnormally hot really fast. Like 30 seconds after a cold start. Feels like I've been riding it all day. Could this be a result of running to lean? If so. How many turns out do y'all do? Also could the problem be that the water pump is leeking out the water pump through the weep hole.? Got the parts comming.. Was jus curious. Thanks

Edited by 99wr400POS

Share this post


Link to post
Share on other sites

My exhaust can burn my hand after 30 seconds of it being on. They all heat up quick and you need to ride it and not let it sit.

Share this post


Link to post
Share on other sites

Not just mine , all of them. They can't even idle more than 5-10 mins without spilling coolant out.

Thats why you see people asking about rigging up a fan to help cool it down

Edited by Stealth13

Share this post


Link to post
Share on other sites

My bike gets abnormally hot really fast. Like 30 seconds after a cold start. Feels like I've been riding it all day. Could this be a result of running to lean? If so. How many turns out do y'all do? Also could the problem be that the water pump is leeking out the water pump through the weep hole.? Got the parts comming.. Was jus curious. Thanks

Obviously, youi have to deal with the water pump problem.

After that, deal with your jetting. Its not simply a matter of turning out the fuel screw. You have to have the right pilot jet first, then adjust the fuel screw accordingly.

See the jetting guide, of simplify your life and get the JD jetting kit like many of us do.

Share this post


Link to post
Share on other sites

Ohhhh ok. Well thank y'all for the help. I didn't know if it was normal or what.this is the first 4stroke I've owned. Starting to like em.

Share this post


Link to post
Share on other sites

Uhh, mine can idle for more than 15 min (maybe more, but haven't tried) without spilling a drop of coolant. Fix that water pump leak then if you are still having problems maybe try changing out your coolant if it's old.

Share this post


Link to post
Share on other sites

I've got a Vapor computer on mine, and starting up cold and letting it idle 2-3 minutes it is easily at 150*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0