HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Stealth13

Question about mud and power

3 posts in this topic

I was riding my bike in a lot of swampy areas and it seemed to lose a lot of power as I rode it more. I then raced my buddies 250 and it felt slow and topped out at 130 and wouldn't go anymore... Does mud/dirt get into certain spots and do this?

Because before I could rip it up to 150 and a lot quicker.

Share this post


Link to post
Share on other sites

Could be your air-filter getting dirty restricting airflow, excessive weight of the mud, extra drag on your drivetrain, maybe even the breather hoses getting slightly plugged. Definitely clean around your front sprocket, chain guide, and anywhere else you may have rotating parts that could get gunk in them.

Share this post


Link to post
Share on other sites

Ya I washed it and it was back to normal. Kinda sucked how a exc250 was only like 20 meters behind by 130...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0