HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
freeriders98

99 WR400/426 oil leak?

2 posts in this topic

So I just picked up a WR400 rebuilt to a 426. It has an oil leak. Seems to be coming from around either the shifter, or from behind the front sprocket. I looked on the TT OEM parts store and found a seal that is on the shifter, but could not find anything showing a seal behind the front sprocket. So 2 questions, do I need to order a 400 or 426 oil seal kit. And is the Moose or Winderosa kit better?

Here is a link to the bike I bought which outlines the 426 build stuff.

http://www.bayareari...ad.php?t=396058

And here are the oil seal kits I am looking at.

http://shop.thumpert...kets-Seals-c19/

This is the oil seal I found and think it might be #8

http://shop.thumpertalk.com/oem.php?partcategory=320672&manufacturer=7&category=3&year=1999&model=6395

Any help would be much appreciated!

Edited by freeriders98

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0