HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
craigbricknell

The 450x and it just died after a buzzing sound up front? No electrical?

4 posts in this topic

Just pulled, cleaned and reinstall a blocked carb to my CRF450x, hit the starter button and it started beautifully but then as it was idling for a very short time I heard what I think was a sizzle from the front area of my bike. and then it stopped with a complete loss of electrical power . nada nothing. checked the 2 fuses, swapped them out but they are ok?

So I have no power at all.

What next?

Relay?

Craig Bricknell

Sydney, Australia

Share this post


Link to post
Share on other sites

Well actually I now very embarrassed!.

The problem was when I thought I was checking the fuse near the battery I was just pulling an reinserting the spare fuse in the rubber holder that holds the relay and the real fuse holder.

Changed it and it started first go.

Thanks for the sugestions.

Craig

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0