have a quick question about the clip in my rear caliper

Hey guys!!

i got a 09 yz450f and i bent my rotor a few days ago and i now replaced it with a new one and today i was puting my (new)stock pads in when i saw that the bottom retainer clip(where i think the pads slide) is bent and broken.

So I was like no big deal, and i went on tumpertalk's microfiche and i saw that there was no retainer clip you can get from yamaha.

Has any one broken or bent this clip? Because i really dont want to buy new caliper just to get a clip.

Does anybody else make one or am i looking in the wrong place on the microfiche?

thanks guys and god bless

Alex

Do you have a picture, or can you tell us where the clip attaches in reference to the parts fiche callout numbers?

http://www.oemdirtbikeparts.com/product-p/006055-10.htm

Look at the 2nd picture on the page. And you'll see the caliper with the red pads. Now look on the left side of the caliper, and you'll see a little metal clip. Thats the clip im talking about. Its on the opposite end of the pin the holds the pads in place

I think if you look up the diagram for the rear brake caliper it is #6 (part number

5DH-25919-50-00, Support, Pad)

http://shop.thumpert...008&model=12951

For some reason the TT OEM parts only go to 2008, but Motosport.com shows the same part number for the 09

hahah thanks for the post. But i actually need the other clip, but the microfche doesnt show it. That clip is by the pin, i need the other clip.

this is fron the front caliper but it may help you guys out

http://www.motosport.com/dirtbike/oem-parts/YAMAHA/2009/YZ450F/FRONT-BRAKE-CALIPER

Look at #15 thats what the clip looks like, but thats the front caliper. i cant seem to find it for the back.

I am thinking that is the same part, just a bad picture in the diagram...? Does your caliper have one front and rear? My 06 only has the one clip

I am thinking that is the same part, just a bad picture in the diagram...? Does your caliper have one front and rear? My 06 only has the one clip

I beleive so. There is one clip right where the pin slides through to hold the pads in place. And if you take the pads out you see that clip in the bottom where i think the pads slide at. I bent my rotor and i think thats what bent and broke the clip.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now