09 YZ450F Puking Gas From Vent

Hola,

I haven't been riding my YZ much since December 2010 as I have gone to the dark side of racing atv's, but have noticed a few issues with my bike when I've ridden it a couple times this year.

Lately it's been puking gas out of the vent cap on the gas tank. Enough gas to make a mess of the fender and it has never done this before. I have also noticed it will occasionally puke coolant out of the black tubes that run along the frame. Temperatures have been mixed between 80's down to 50's. Riding style has been 3rd through 4th gear but I seem to notice the issues crop up when I'm riding through tight terrain in 1'st gear. I have also noticed a hissing noise coming from the gas cap when I shut the bike off after riding for awhile. Any ideas on where to look?

Good luck. I also have an 09 yz450 and my cap has been leaking gas on the front fender since I got it. I bought a new short vent for it so now it spews gas on the tank. I don't know what else to do. My buddy has a 09 yz 250f and we switched caps and mine leaked on his bike and his did not leak on my bike. With two vents I guess it is possible I got 2 back to back defective vents but not likely. The common denominator is my cap. I took it apart but it did not help.

My 07 did the same thing. I drained the fuel and replaced it with new. I also changed the coolant and went with engine ice to keep the temp down. I believe the fuel was the main issue though.

Sounds like the cap is not venting properly. The heat from the motor is warming the fuel in the tank, and it's not venting the excess pressure caused by this until it's elevated, which causes it to spew fuel. Maybe you can just drill the check valve out of the cap, or replace it with an aftermarket cap, and find an inline check valve like they used to come with.

any idea if they fixed this issue on the new bikes? id like to buy a newer one and try it. i have this issue on mine and put several valves on it to no avail. i wish the cap on my YFZ would fit, you can fill it to the brim and no spills whatsoever.

I think if you replace your gas cap you'll fix the problem. My '06 doesn't do this but just a very small amount if it's really full.

I might have to try and replace the cap. I'm still using the original gas cap and vent. I cleaned most of the issue up by fixing an exhaust leak. I think the leak was causing the bike to run poorly which was making the bike heat up at low speeds. I've only ridden it once since I've fixed the exhaust leak but the amount of fuel puking out the vent has been reduced substantially.

I think if you replace your gas cap you'll fix the problem. My '06 doesn't do this but just a very small amount if it's really full.

so it probably would be best to go with an aftermarket cap to avoid getting a bad oem one then?

That would avoid getting a bad OEM cap, but not a bad aftermarket cap. I've never had an OEM cap not work right.

very true :thumbsup:

Got my new cap today (aftermarket) filled it completely, took it to the track this evening, not so much as a drop.

has anyone modified their oem tank cap so it doesn't leak so much? I have an 08 yz450f and it leaks a lot out the aftermarket breather check valve on the cap. I have put two check valve vents on it from cycle gear (trackside brand) and it still leaks.

Good luck. I also have an 09 yz450 and my cap has been leaking gas on the front fender since I got it. I bought a new short vent for it so now it spews gas on the tank. I don't know what else to do. My buddy has a 09 yz 250f and we switched caps and mine leaked on his bike and his did not leak on my bike. With two vents I guess it is possible I got 2 back to back defective vents but not likely. The common denominator is my cap. I took it apart but it did not help.

BUY A NEW CAP! :banghead:

 

MAX!!!

I have had this issue on every Yamaha I have had since '06 (5 of them now). I find it hard to believe that I have somehow gotten 5 bad gas caps and have always thought it was a design flaw on Yamaha's part. Either way, I have just gotten used to running yellow fenders :(

I'm on my 3rd yz and have never heard of this issue until this thread.

 

MAX!!!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now