07 YZ450 backfire

So I finally got my bike back together after replacing a stator and right side radiator. Bike has a major backfire going. Now I used some gas that was alittle older than I would have liked to put in it but I really wanted to see if it would start.

So could this backfire be from the old gas? Could my hot start be stuck open? It has a new plug.

Thanks for your input!

check to make sure your exhaust is tight and not leaking.

I'll check again, I did pull the pipe to change the oil filter. When I started it outside in the dark and it was idling the head pipe was glowing red. It did go back to normal after I took it up and down the street. Thanks

When I started it outside in the dark and it was idling the head pipe was glowing red. It did go back to normal after I took it up and down the street.
That's normal.
So I finally got my bike back together ...
Sounds like it sat for a while. You probably have a varnish deposit in the pilot jet making the bike run lean. And, yes. start with fresh fuel.

Thanks everyone. I drained the tank and cleaned the carb while I was was waiting on parts so I'll start with the gas. If it does the same thing I'll pull the carb again... Wouldn't be the first time I didn't clean a carb good enough. Thanks

So I replaced the gas with fresh 92 octane and still had the backfire. Brought it back in the garage to start the process of pulling the carb. Pulled the main and pilot (48), they looked good but I cleaned them again. Put it all back together and..... Still backfire on decel. Checked head pipe and it worked itself loose. Tighten that up and it sound better at idle but still had a backfire on decel when going up and down the street.

Could this be just a jetting issue at this point? Last time I rode it was in the 60's. When I've been testing after working on it after work it's been in the 30's and 40's. I'm at 4800' and it is getting cold.

Bike idles fine with choke on but a little rough with the choke off.

When I put the carb back together I close the air screw all the way. Opened that up about 1 1/2 turns and ran much better

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now