02 YZ 426 water leak issue

I've got a terrible water leak. Its coming from a small hole on bottom of case. Anybody know if this is a weep hole? I took a picture of it but cant seem to imbed it. :busted:

So I took off cover to water pump... before taking it all apart, is there some kind of diagram or reference material I can refer to so I know what to replace? thanks..

I've got a terrible water leak. Its coming from a small hole on bottom of case. Anybody know if this is a weep hole? I took a picture of it but cant seem to imbed it. :busted:

So I took off cover to water pump... before taking it all apart, is there some kind of diagram or reference material I can refer to so I know what to replace? thanks..

Check the Yamaha web site. They have parts diagrams and I think that you can access the owners manuals too.

Just because the Common Threads sticky says, "look here first" is no reason to actually look there...:busted:

http://www.thumpertalk.com/forum/showthread.php?t=940018

Good point. There's no way someone's problem could possibly be a common one, lol

To answer your question, your water pump seals have failed.

Check the sticky's at the top of the forum page for how to repair this. Best you replace the bearings and seals, and possibly the shaft.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now