Sign in to follow this  
Followers 0
N8KANE

Tusk dual sport kit headlight issue 006 WR450f

6 posts in this topic

Ok, so I wired this kit up about 6 months ago and decided to leave the front headlight alone. I have been on vacation the last couple of days and decided that would be an easy project to complete. Not so so easy! I wired it up to the switch, everything seems to work except the high low switch. It will turn off and on fine but just stays on low beam......

Anyone else have this issue?

Before you ask.....yes it's a dual filament bulb!

Share this post


Link to post
Share on other sites

On my 04 model the factory plug has the place for the terminal but no terminal to the high beam. Might be your issue?

Share this post


Link to post
Share on other sites
Ok, so I wired this kit up about 6 months ago and decided to leave the front headlight alone. I have been on vacation the last couple of days and decided that would be an easy project to complete. Not so so easy! I wired it up to the switch, everything seems to work except the high low switch. It will turn off and on fine but just stays on low beam......

Anyone else have this issue?

Before you ask.....yes it's a dual filament bulb!

I have a 2007 wr450 so might be different but I had to splice into the high beam if memory serves me right. It was not a straight plug in. I can find my notes if it is not answered definitively soon.

Share this post


Link to post
Share on other sites

I have 3 wires coming out of the back of the lamp...blk/ground which I didn't touch. Yellow / power which I tapped into And ran to the switch and brown which I tapped into for what I thought to be the high beam....I also connected the other yellow wire from the lamp for low beam?

Not sure what went wrong ..... I'm going now to look at the other terminals and try that?

Share this post


Link to post
Share on other sites

Ok...just looked the yellow and blue wires are going to the same terminal?...yes I know I said they were brown before...they are blue....lol!

Share this post


Link to post
Share on other sites

See if this works - All you are doing is hooking the black wire from your control switch to the stock power wire for your head light, this powers the switch. Then you take the blue wire and hook it to your high beam lead and hook the white wire to your low beam lead. That is what I did on my 2007 WR450f and it works great. Hope it helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0