HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Barry22

Help WR 450 Cutting out after AIS kit

4 posts in this topic

I just got my 08 WR 450 back from the dealer who installed the AIS kit. It ran great first 30-45 minutes. Then after a few open throttle runs (drag racing my friend on his DRZ 400) it started cutting out and losing power like it was starving for fuel or air. I live in Dallas,Texas so I don't think the jetting is a problem. After continually working the throttle more the loss of power goes away and then randomly happens again throughout the day. I didn't have them remove the gray wire on account of what I read is that it is just a rev limiter. My fear is that I will climbing a hill and it will start cutting out again. Does anyone have a suggestion? :thumbsup:

Thanks

Barry

Share this post


Link to post
Share on other sites

the grey wire is a more aggressive ignition mapping from the CDI.

Not sure this is the root of your issue though...

You didn't say if you installed the jet's and needle that come with the AIS kit.

The first thing I would check though is that your fuel tank vent is working properly and it's not causing a vacuum in the tank starving you of fuel during harder running.

Share this post


Link to post
Share on other sites
I just got my 08 WR 450 back from the dealer who installed the AIS kit. It ran great first 30-45 minutes. Then after a few open throttle runs (drag racing my friend on his DRZ 400) it started cutting out and losing power like it was starving for fuel or air. I live in Dallas,Texas so I don't think the jetting is a problem. After continually working the throttle more the loss of power goes away and then randomly happens again throughout the day. I didn't have them remove the gray wire on account of what I read is that it is just a rev limiter. My fear is that I will climbing a hill and it will start cutting out again. Does anyone have a suggestion? :thumbsup:

Thanks

Barry

Yes, take it back and make them fix it while you wait.

Share this post


Link to post
Share on other sites

Thanks. I will check that. I did have the dealer install the jets and needle that came with the kit.

Barry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0