HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
tl1000rlt

Having trouble with a coolant leak.

4 posts in this topic

03 YZ450, the leak is coming from the front of the engine where the radiator pipe hooks in the engine, right next to the exhaust. I have taken it apart twice and replaced the O ring but I cant get it to stop leaking. I also have the pipe insert that goes into the head but I cant get the old one out. Any suggestions how to fix or what I am doing wrong? It sure seems to be a sloppy fit the way it goes together there.

Share this post


Link to post
Share on other sites

Dealer sent me wrong part. Im going to try to get an o ring of the right size at the hardware store. If it keeps leaking Ill get pics. thanx

Share this post


Link to post
Share on other sites

Ace hardware is my new o-ring outlet. They have hundreds and at 60-80 cents a peice, they are way cheaper than cycle related sites or dealers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0