HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
nathan-yel

problem with 06 wr450f

8 posts in this topic

hey fellas im only new to this forum.

i acutlly only made an account today so i could try and get some help with this problem.

all off a sudden my oil seems to be disapearing into my radiator and is leaking out of the bottom left hand corner of the right radiator on the right had side just somewhere above the header pipe it has all of a sudden done this im not sure if the radiator has a split in it or what is going on. i was thinking it is possible as i have just put alloy radiator guards and may be rubbing but even if that is the case im still left to wonder what the oil is doing in there?

cheers fellas any info would be much appreciated.

cheers nate

Share this post


Link to post
Share on other sites

Remove all Advertisements

hey fellas im only new to this forum.

i acutlly only made an account today so i could try and get some help with this problem.

all off a sudden my oil seems to be disapearing into my radiator and is leaking out of the bottom left hand corner of the right radiator on the right had side just somewhere above the header pipe it has all of a sudden done this im not sure if the radiator has a split in it or what is going on. i was thinking it is possible as i have just put alloy radiator guards and may be rubbing but even if that is the case im still left to wonder what the oil is doing in there?

cheers fellas any info would be much appreciated.

cheers nate

Share this post


Link to post
Share on other sites

I don't know about the wr's but on my Yz450 there is a plug in the cyclinder where the manual decompression was located on the older models. It is almost looks like a freeze plug. It sounds like yours has come out. Mine did the same thing. Easy fix

Share this post


Link to post
Share on other sites

What year WR, 03-06? Guessing here but you owe me if I'm right:

There is a manual decompressor plug where the older WR's had a manual decompression lever right above the header that likes to fail/fall out and will spray oil towards the radiator when running.

It's a common issue and either put in another Yamaha plug and watch for it to happen again and do the same thing in a few seasons or search in the Stickys and someone makes a metal plug that should last much longer. The plug is right above thhe header which you can see and feel fairly easily.

If that's not it, sorry, no idea how oil can leak out a radiator like that.

Mike

Share this post


Link to post
Share on other sites

I replied the same thing to your other post, it's the plug. Located on the head above the header. Search the forum for it, LOTS of info about it.

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0