HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
cgtrimcarpentry81

what to look for?

2 posts in this topic

i have a 2000 426 bought it a month ago had 2 rides on it.changed the oil and filter..power seems alot better after oil change but at low speed the engine will kinda of studder.

Share this post


Link to post
Share on other sites
i have a 2000 426 bought it a month ago had 2 rides on it.changed the oil and filter..power seems alot better after oil change

It's likely that whatever power difference you're feeling after you changed the oil is either imaginary or from some some other factor. (temperature perhaps)

For your engine stutter I would start by cleaning the carb and making sure your pilot jet isn't clogged since the bike sat for most of it's life. If everything is clean and your pilot is the correct size you could try a smaller leak jet, and check your ap timing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0