Sudden Rattling or knocking noise 2009 YZ450

Today while riding my engine suddenly started knocking or rattling loudly. I was able to limp it off the track but can't quite tell if the noise is coming from the top or bottom end. The engine starts and runs without a miss but has a knock or rattle that is very loud and sounds like possible piston slap. Anyone have any ideas what this may be? When I get some time I will pull the top end to look at and change the oil to see if there is any debris in the filter etc. It was running fine up until that point. I only have about 12 hours on the new top end but it has ran fine till now which makes me wonder if something happened on the bottom end. If anyone has any thoughts let me know! Thanks!

did you replace the cam chain when installing the new top end? Could of jumped timing.

KJK_JR, yes I was able to tear it down that far tonight and checked the timing which is still ok (13 pins on the chain between the 12 o'clock marks on the cams). It seems to run fine other than the knocking/rattling noise which like I said earlier leads me to think it may be something in the bottom end. Let me know if you have any other suggestion and thanks for the quick reply!

It could be a lot of things, but the first thing that came to my mind is a bad big end rod bearing.

the timing ... is still ok (13 pins on the chain between the 12 o'clock marks on the cams).
That is NOT an indicator that it's timed right. Read:

http://www.thumpertalk.com/forum/showthread.php?p=7467845#post7467845

Another thing that can result in a sudden knock/rattle is damage to the piston, rings, and/or cylinder wall. It may have scored the skirt, causing piston slap, tossed a circlip, or a number of other things.

You might see if the noise goes away when you pull the clutch in, or put the bike in gear. Something loose in the primary drive, or a broken tooth on one of the other 7 gears in the right side is something else to explore.

Today while riding my engine suddenly started knocking or rattling loudly. I was able to limp it off the track but can't quite tell if the noise is coming from the top or bottom end. The engine starts and runs without a miss but has a knock or rattle that is very loud and sounds like possible piston slap. Anyone have any ideas what this may be? When I get some time I will pull the top end to look at and change the oil to see if there is any debris in the filter etc. It was running fine up until that point. I only have about 12 hours on the new top end but it has ran fine till now which makes me wonder if something happened on the bottom end. If anyone has any thoughts let me know! Thanks!

Like Gray commented, first isolate if it's tranny or engine related. Start the bike slightly rev, and listen with the clutch engaged and dis-engaged. If the sound goes away with the clutch pulled you have a trans/clutch issue. If you hear the rapping all the time, you have an engine issue. All's you can do at this point is start dissasembling the top end, and you should find out very quickly where the issue lies.... I'm taking a guess that you have a piston issue. A common mistake is the pin circlip that was improperly seated (or forgotten), and poping out of it's groove and trashing the top end...

That is NOT an indicator that it's timed right. Read:

http://www.thumpertalk.com/forum/showthread.php?p=7467845#post7467845

Another thing that can result in a sudden knock/rattle is damage to the piston, rings, and/or cylinder wall. It may have scored the skirt, causing piston slap, tossed a circlip, or a number of other things.

You might see if the noise goes away when you pull the clutch in, or put the bike in gear. Something loose in the primary drive, or a broken tooth on one of the other 7 gears in the right side is something else to explore.

Gray and all thanks for the reply. I guess I should say I believe the timing is correct because at TDC the marks at the cams are flush with the valve cover (3 o'clock and 9 o'clock) and then there is 13 pins between the 12 o'clock marks. The noise does not change when the clutch is engaged or disengaged so maybe it is the top end. Would it still be able to run and seem normal (other than the rattle) if it was the piston or valves? I probably won't have time to tear further into it until this weekend. Could it possible be something like the timing chain tensioner failing? Any other info would be greatly appreciated!

When the timing chain gets loose it sounds like a bunch of pennies in a tin can (typically right before jumping time). If your timing is right, and your valve clearances are right then I doubt it is anything with the valves. There isn't much with the piston that could make a noise like that except for possibly piston slap, or excessive wrist pin play. If the piston were worn enough to slap like that though it typically will turn the piston sideways in the cylinder due to the short skirt rather than continue to just make a knocking sound. You're really going to have to just tear it down and see what you find though since it could be so many different things.

A friend of mine had a similar issue with an 06 YZ450F. It turned out to be a broken wrist pin. It stayed together somehow and didn't do any other damage.

With the very small skirts used on the "slipper" style pistons in these engines, it takes very little damage to create a lot of noise, and the fact that it rattles does not necessarily mean it's going to explode soon (doesn't mean it won't, either). I've seen at least one example of an engine with slipper pistons where the second ring on one piston snapped roughly in half, did no damage, and caused a very loud piston slap, even though the piston itself was basically unharmed.

Just one other thing, though. If you have an aftermarket skid plate, take it off and see what happens.

It could be a lot of things, but the first thing that came to my mind is a bad big end rod bearing.

Thats what I'm thinkin too! Maybe drain your oil and pull your oil filter out and seeif you see anything. If the crank is shot you will usually see lots of gold or copper looking shavings.

Thats what I'm thinkin too! Maybe drain your oil and pull your oil filter out and seeif you see anything. If the crank is shot you will usually see lots of gold or copper looking shavings.

I had one like this, the oil and filter were clean. Tore it down and found the big end rod bearing had gone bad. When I split the cases I found the strainer in the sump full of pieces of the bearing cage. I guess no pieces were small enough to get through the strainer and into the filter itself.

Like Gray commented, first isolate if it's tranny or engine related. Start the bike slightly rev, and listen with the clutch engaged and dis-engaged. If the sound goes away with the clutch pulled you have a trans/clutch issue. If you hear the rapping all the time, you have an engine issue. All's you can do at this point is start disassembling the top end, and you should find out very quickly where the issue lies.... I'm taking a guess that you have a piston issue. A common mistake is the pin circlip that was improperly seated (or forgotten), and popping out of it's groove and trashing the top end...

Got it tore down and unfortunately Polar Bus you are correct. The circlip popped out on the timing chain side and the the wristpin has contacted the side of my cylinder and left a groove that has likely trashed the cylinder wall!:lol: So now it looks like I get to buy a new cylinder and piston kit etc.:ride: My question is how lucky would I have to be to find and remove the circlip from the bottom end without splitting the cases? I may try to fish around with a magnet and hope for the best. Thanks for all the comments and ideas of what was causing my sudden rattle.

Edited by opie

So anyone have an idea if I will be able to find the circlip fishing around with a magnet in the bottom end? I won't be able to try until Friday or Saturday and was curious what my odds may be. It came out on the timing chain side so maybe I got lucky and its stuck to my magneto. Let me know what any of you think or maybe have suggestions on how to find it. Thanks!

I had the same problem with my 09,i must not have inserted my circ clip all the way in and after about 30 hours the wrist pin was scratching the hell out of the cylinder wall and was making the sort of noise you said you heard!

  • Always use a new circlip
  • Bend it as little as possible when installing
  • Put the end gap of the clip at the top (important)
  • Be certain it's completely seated
  • NEVER use a different type of clip than was supplied by the piston manufacturer

So anyone have an idea if I will be able to find the circlip fishing around with a magnet in the bottom end? I won't be able to try until Friday or Saturday and was curious what my odds may be. It came out on the timing chain side so maybe I got lucky and its stuck to my magneto. Let me know what any of you think or maybe have suggestions on how to find it. Thanks!

Did any part of the piston skirt break off ? If so, most likely all the piston fragments are down inside the crankcase as well. My advice at this point is it would be very wise to split the cases for an inspection and cleaning. If you start cutting corners now you could be faced with a 3rd rebuild shortly after the current one. 4 strokes have a lot of advantages over 2 strokes, but you are experiencing the major disadvantage which is wallet sucking repair costs. At least now you know where your issue lies and time to fix it and get riding again trouble free...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now