09 WR450 Oil Help nub

its all good now:)

Edited by dep411

oh and i never had any oil come through the check oil like its says in the manual if its been overfilled... where did my 2.2Q of oil went is a mystery to me...?

oh and i never had any oil come through the check oil like its says in the manual if its been overfilled... where did my 2.2Q of oil went is a mystery to me...?

Check if you have air pressure building up in the oil tank. There is a pipe which runs from the tank to the engine case (clutch side) If there is a block somewhere, then the tank cannot fill and oil will not circulate.

Check if you have air pressure building up in the oil tank. There is a pipe which runs from the tank to the engine case (clutch side) If there is a block somewhere, then the tank cannot fill and oil will not circulate.

I did check that breather it was clear and when started it was blowing out air..

i started it up and oil is definitely reaching the oil filter ,

So this is where I am in this problem or is it. Oil is reaching the filter (so I'm guessing the pump is working) But the dip stick dose not read at all and the oil pressure weep test dose not work.

I read that if you put much oil in it oil should come out of the oil check. Which I put in 2.2 quarts and nothing came out of the check hole...

Edited by dep411

Just a thought: I am wondering if 2 quarts is way too much oil. Is it possible that something like the crankshaft is striking a pool of oil and causing it to foam, which then prevents the oil from being pumped. If so, very scary since no lubrication is occurring.

I'd say drain the oil. Based on my '06, just 1.0 quarts is required to refill without a filter change. Then repeat the test with running only a minute or so to minimize the risk of damage if oil isn't circulating properly.

If the bike is in fact a "works" machine it may have been converted to a wet sump oiling system (god knows why). There were a handfull of early YZF's that were converted years ago but it was a fad that passed. There is no way of knowing since the old bikes that were converted had external oil lines to the oil tank (in the frame) that were removed/relocated but the aluminum frame bikes have the oil tank incorporated into the front of the engine cases. if oil is pumping to the filter but not out the bleed screw located just ahead of the carb on the left side of the bike there is either very low oil pressure or a blockage in the oil path in the righ side case, cylinder, or head. If this bike was converted to a wet sump all of the oil sits in the bottom of the crancase and none will be in the oil tank (where the dip stick is).

Paul Whibley is a Factory level woods racer for Yamaha , mostly. If it was his bike, the lights, starter, battery, and extra wiring would be gone, and it would have an oversize gas tank.

I doubt the bike would be wet sump, unless you see and external tank. I'm with 06wr, drain the oil and try with 1 QT. Check the weep hole to make sure it is pumping. My 07 picks the oil right up after a change.

Paul Whibley is a Factory level woods racer for Yamaha , mostly. If it was his bike, the lights, starter, battery, and extra wiring would be gone, and it would have an oversize gas tank.

The oil dose sit in the crank case, So I did dumped out all the oil and put 1.2Q per manual.. I guess This is how I see it as, if I rode it twice without anything bad happening I guess everything should be working...Can't break anything by doing a simple oil change...

I really wish i would of done the weep test before I changed the oil and I should of measured what came out of it. Oh well I'll see if i seize the motor Sunday :cheers:

I ran into the same issue while changing the oil for the first time in my new-to-me '09. I was using a gallon container of oil so I didn't know exactly how much I'd put in. The dipstick kept showing no oil at all even though I'd put in what was definitely more than a quart. I eventually drained the oil back out into a a big measuring cup and poured exactly 1 quart back in. I couldn't get a proper reading on the dipstick until after running the bike for a few minutes, letting the oil settle for a couple minutes, and then re-checking.

yes i rode the piss outta it today and nothing seized and felt great. it was converted to a wet sump sys so all is good

thanks everyone

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now