99 WR400 Rebuild

i wonder how much that'd cost... i've always wanted to go to austrailia...lol. ship mine over too and go ride :confused: or buy my 07 and i'll deliver

wouldnt be much at all around $500 for memory, a mate of mine brings in bikes by the container load, all 70's jap bikes and indians/harleys.

would just have to strip it down to get past customs :thumbsup: and pay tax on it.

Only problem is that it then it couldn't be registered as it needs to be complied.

I would put stainless braided brake lines on it while you are there, and a new wiring harness should be in the range of 70 or 80 bucks (in the states it is anyway).

It looks like you have the original lines on, which are what, 12 years old now.

Well my new Wiseco piston turned up from the US today, hopefully ill get some time on the weekend so i can finally start piecing the engine back together.

I really want to go out riding but we are heading into winter so its getting a tad cold for my liking so i wont be rushing the build.

Im finally back on top of this project, after moving house and getting married i have some more money to spend on the bike.

Just a few things to update on but no pics yet.

I have pulled the motor back out and split the cases after finding the 4th gear pinion was half missing, i ordered the bits from the Thumpertalk shop earlier so hopefully i should have them in a few weeks so i can start putting it back together.

I also came across a box of parts on ebay that had the swingarm pivot assembly in there and a heap of bolts after i had to cut mine off the swingarm , i dont think it had ever been apart and the bearings just fell to pieces.

I just have to sand blast all the bits and paint and then reassemble.

Im really hoping the motor runs and everything works when i get it back together its the first time i have pulled one down this far.

I will take some pics over the weekend of how it sits now and the mess that is the motor.

Glad to see you are back at it. Looking forward to the pics.

nice i was wondering where this was at... i need to go get my engine and swing arm soda blasted but the nearest guys an hour away. I've got a thread on mine up now :smashpc:

All the parts turned up from the Thumpertalk shop this morning cant wait to get home and start putting the engine back together.

Ill have to remember to get some pics up.

Here a couple of new pics, i started reassembling the engine last night should have it in by the weekend.

IMG-20111004-00229.jpg

IMG-20111004-00231.jpg

The stuffed 4th gear pinion.

IMG-20111004-00230.jpg

IMG-20111004-00227-1.jpg

Lookin great!

looks good man! hopefully my motor doesn't end up all in pieces too...lol. havn't touched it

IT LIVES.

th_wr400.jpg

I spent a bit of time on it on the weekend and put the engine back together and back in the bike, i thought id see if it would start so i put the tank on and gave it a few kicks. she fired up after about a dozen kicks and just sat there idling away, best thing is nothing leaks or rattles lol.

IT LIVES.

th_wr400.jpg

I spent a bit of time on it on the weekend and put the engine back together and back in the bike, i thought id see if it would start so i put the tank on and gave it a few kicks. she fired up after about a dozen kicks and just sat there idling away, best thing is nothing leaks or rattles lol.

Mark,

Sorry bud, but that second video you have on your PB account got my attention:smirk: The WR engine be damned.

Smoking hot!

Anyone you know?:thumbsup:

Mark,

Sorry bud, but that second video you have on your PB account got my attention:smirk: The WR engine be damned.

Smoking hot!

Anyone you know?:ride:

haha i saw that on there and was almost going to post that up as i knew you guys would appreciate it.

no one i know unfortunately :thumbsup:

haha i saw that on there and was almost going to post that up as i knew you guys would appreciate it.

no one i know unfortunately :ride:

Back on topic - Good job with the motor (and the bike):thumbsup:

Its almost complete :thumbsup: all i need to do now is bleed the brakes, install the new throttle cable and chain guide and its done. The only thing i havnt touched yet is the wheels but i will go out for a few rides first and then pull them off for restoration.

I actually rode it around the back yard for a few laps and i cant wait to get out to a track.

IMG-20111016-00008.jpg

IMG-20111016-00009.jpg

IMG-20111016-00005.jpg

IMG-20111016-00006.jpg

pic of the shock before installation.

IMG-20111014-00002.jpg

130831979143.jpg

i need to pull my engine back out and blast it... the sodas taking forever though and getting all over the place! i don't have a cabinet and with the moisture in the air now it's sticking to everything really bad

Excellent job Mark!!!

Absolutely amazing! Congrats!

Great job.

You probably have them and haven't put them on yet, but make sure you don't forget your header guard and left engine case guard. :thumbsup:

I really wish I had taken the time to paint my frame when I had it apart last. :ride:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now