HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
mikewrf18

WR w/YZF exhaust

1 post in this topic

I have an 07 WR450F with all the recommended mods completed. It has run great for the last couple years with these mods. I just purchased a complete exhaust w/ PMB end cap/spark arrestor from an 08 YZ450F. I installed it the other day, and now my bike is running really lean. (I think) I posted a thread in the carb section, but I know many of you have done this and probably experienced the same issues. If you have done this, and rejetted could you check out my thread in the Intake, Jetting section? I have the carb off again, it was a pain as usual, and I want to get it right so I don't have to pull it twice! All my jetting specs and settings are in that thread. Here is the link.

Thanks again

http://www.thumpertalk.com/forum/showthread.php?t=942732&highlight=

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0