Water Pump Life

My water pump failed after only 40hrs on my 2008, specifically the water seal. I'm replacing the shaft, both seals and the bearing. I have messed around with cleaning up shafts and re-using them. I'd rather spend the $30 on a new shaft and not have to worry about it.

Just out of curiosity, how long have your water pumps lasted?

Mine went at around 200hrs. First I just did the seals and felt like a dummy when seeing what my shaft looked like, but I didn't have the parts, so I threw it together to see how it went. It didn't leak for 100hrs untill last winters rebuild when I replaced seals, bearing and shaft. I now have over 150hrs on my replacement and all is good. Will see how it looks when I rebuild the motor this winter.

4 years and still no leaks on my 2006.

Question to those that are having failures-

Are you running spec coolant? Water wetter, engine ice, etc may not have the same lubrication properties as the recommended coolant.

I run the pink Maxima stuff. I have boiled over my bike a few times recently and I think it just got too hot and damaged the seals.

Anyother thoughts?

I run the pink Maxima stuff. I have boiled over my bike a few times recently and I think it just got too hot and damaged the seals.

Anyother thoughts?

I also use the pink Maxima stuff, well the Kool aide additive added to regular antifreeze/water.

I boil my bike over regularly :ride:

But when I replaced mine the shaft was very obviously worn so I don't think it's boiling and seals????

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now