Stalling WR 450

Thought I had this one figured out, but still happens more often than I like. I'm running an 05 WR450, mostly dualsport lately and it recently just started stalling at stops, or when I would go to take off. I have a JD jetting kit installed, with the 0 ring mod. I disembled the carb figuring a problem with the pilot circuit, blew that out, checked out the fuel screw, appeared that the rubber o-ring was broken, so cleaned the fuel screw orifice out and replaced the o-ring then washer, spring and the screw itself. It seemed better this weekend, but on several occasions it did it again. I will work the throttle before taking off, but occasionally it just quits. Any ideas?

Thanks, Ron

I'm assuming it is stalling due to lack of fuel, not flooding. Have you checked your tank vent to make sure it is working? My buddies WR250 kept stalling and it turned out it was the tank vent stuck closed so a vacuum was developed in the tank and it would quit allowing fuel to enter the carb. Just take it out of the line and try it, it's free to do , also make sure the vent lines are clear under the bike. WR Dave

I had a mate with a similar problem and he traced it to a worn needle. He replaced the needle and it fixed his problems. How old is your JD jetting needle?

I had a mate with a similar problem and he traced it to a worn needle. He replaced the needle and it fixed his problems. How old is your JD jetting needle?

Good call Strattos, just a note on that, if the needle is worn out the needle jet that it slides up and down in has also likely got a groove worn into it and should be replaced. :banana: WR Dave

The needle jet emulsion tube wears way more than the needle. A needle will often last as long as the entire carb. Needle jet emusion tubes have about a 150 hour life span at most.

The kit was put in last year, I was running the red needle and went back to the blue which I believe richens up the lower half. I replaced the stock fuel screw with an aluminum with a knob, but it appeared to be OK. This thing just abruptly quits, no cough or anything like that. Otherwise it seems to be just fine. I may switch back to the original brass and see if it makes a difference, will also check the vent tube on the cap and those running from the carb as well. Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now