IMS tank/radiator shroud problem

I've got a 3.1g IMS tank and YZ shrouds on my 08WR450. I've had it on for a while, but one thing that bothers me about the fitting is that I had to flex the radiators back a bit to get the bottom bolt to line up with the lower radiator shroud hole. Had to flex them back about a quarter of an inch. There's still some flex left if they had to move back any further - such as in a crash, but it still worries me.

Has anyone else had this problem?

Will this risk radiator life? Am I better off getting a file/knife and making the shroud hole bigger?

I just used a couple of longer bolts and put a spacer between the radiator bolt clip and the shrouds. You may have to slightly bend the hole mount area back a bit for alignment purposes, I wouldn't be flexing the rads too much if I didn't have too. Just make sure you have a washer on both sides of the plastic around the bottom bolt hole on the shroud. :banana: WR Dave

Mine were like that too for a little while, after a few hard crashes everything seems to fit just fine...

I just used a couple of longer bolts and put a spacer between the radiator bolt clip and the shrouds. You may have to slightly bend the hole mount area back a bit for alignment purposes, I wouldn't be flexing the rads too much if I didn't have too. Just make sure you have a washer on both sides of the plastic around the bottom bolt hole on the shroud. :banana: WR Dave

+1:thumbsup:

Thanks guys. Might have another crack at mounting them. Cheers.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now