08 wr 450 starter motor

i lads, im hoping some one will read this thread and help me out, ive got a wr 450 on a 08 reg, alloy frame and my battery went dead, ive charged the battery and put back on the bike but when im going to fire it up by the elec start,its just clicking, wey one click, ive wd" the wireing incase it got wet ect and ive chased all the wires down to the starter but no wires caroded or broke ect,ive also put some jumpleads of my other bike and still no good so no its not the battery, im hoping someone has had this problem and can help me out, ive had te bike a year now and i can honestly say its the best thing ive ridden, i use it for greenlaning and it performes pefect for the job !!!

hope yous can help, cheers john :eek::ride:;):ride::banana::thumbsup:

my starter got smoked on the overhaul . I got a new one because I was tired of waiting for my bike . Anyhow I since have pulled the old one apart . mine just needs a new set of brushes . I bet the same it wrong with yours . yamaha sell them for like 12 bucks get a set and try it.

my starter got smoked on the overhaul . I got a new one because I was tired of waiting for my bike . Anyhow I since have pulled the old one apart . mine just needs a new set of brushes . I bet the same it wrong with yours . yamaha sell them for like 12 bucks get a set and try it.

cheers for that mate, do u have a phone number for the place u bought yours from, bearing in mind im in newcastle, england, ill give them a shout before i pay 300 pound for a new one, just my bloody luck i tell ya !!! i just hope it is brushes, or its kick it till i find the cash !!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now