bought 06 YZ450F

So I bought this bike for 2100 bucks.

here some stuff that came with it

JD jet kit

two bros full exhaust

excel wheels???Were these stock that year?

full iron man sprockets and regina chain

some zeta levers

Other than that is has OEM plastics and all that cool stuff.

So first thing I did was start it up, it actually started! I rode it around a little. it was poppin on decel and doing all kinds of evil stuff. So I know what to do and I check the valves and timing, one valve was way off on the intake .35! .15 is max spec!!! So i shimmed that one, the rest were fine. The timing was OFF THE EFFING WALL!!!! I set the flywheel to TDC, looked at the cams and each were off at least 8-10 teeth! couldnt believe it even started let alone ran. So I fixed those. Just thought I would tell the story. lol Do I need triple trees for this bike? Anything else to know? Also this one has the Ti shock spring??

Cannot believe it was off 8-10 teeth and did not contact valves. Very lucky. If timing was off get a new timing chain and maybe a new tensioner. Steering stem bearings usually need attention. Are you track or trail? Excel was stock.

It does come stock with a ti rear spring.

Id change that timing chain and tessioner asap as I dont think its possible to assemble the bike with the timing that far off. How did it run after you changed the timing and shimmed the valve?

Its a great bike, I think these years turn just fine however, many people swear by the 22mm offset clamps.

The tensioner and chain seemed good, the bike doesnt have many hours on it, I can tell by checking all the bash and smash points on the thing. Anyway, I checked how far out the tensioner was and it wasnt out far, around half way. I havent gotten to start it because I dont have an airfilter, I will go get one temporarily while Im waiting for my order from RMATVMC. With the timing fixed and valve adjusted, this bike should be a champ. thanks for the responses and tips guys. I just wanna test it tonite on an MX track for like 20-30 mins.

are you positive the valves and timing was that far off? did you use a manual? have you started it yet since you made the adjustments?

dude I am absolutely sure they were off that far. this is not my first rodeo here doing valves. I have done them before and have never had a problem. I brought the piston to tdc, then checked marks, simple. They were off so I fixed them then checked the valves. only one was off, really off, the others were fine. The thing accelerated well though, I couldnt believe it when I saw how far off the ccams were. like I said it was popping backfiring doing all kinds of terrible stuff on decel. I tried the fuel screw and that didnt help at all, so in my head I was like timing! it was also very chatty and loud when idling, so I was like the cams valves need attention.

I followed the manual step for step. no start since, dont have an airfilter yet.

i'd replace the chain and tensioner before it jumps again on your next ride. i understand the not your first rodeo thing but it ran before and now it doesnt. there are several marks through the hole. hope you get it sorted out.

edit:maybe you havent tried to start it yet since you dont have an airfilter yet. hope it runs great but i'd still replace the chain and tensioner.

my '06 needed the shift stopper part update, steering bearings, and fork seals (all common for these bikes) I went ahead and replaced the cam chain too as some had instances on slipping time (like yours) For $25 you really should replace that cam chain

my '06 needed the shift stopper part update

Hey, Luigic81!!!

Is this shift stopper that little spring loaded arm that has a roller bearing that sorta indexes the shift drum? :banana:

My ridin' buddy has an '03 or '04 (steel frame) YZ250 2-stroker. That part I attempted to describe above had the roller bearing come apart, and went all through his tranny, wreaking much havoc..... ;) It took out several gears, a shift fork, & such..... It scares me to think of what it could do to one of our bikes...... :eek: This is the first I've read of such deal on the big thumpers..... Would anyone have a part number for the updated part?

Jimmie

i'd replace the chain and tensioner before it jumps again on your next ride. i understand the not your first rodeo thing but it ran before and now it doesnt. there are several marks through the hole. hope you get it sorted out.

edit:maybe you havent tried to start it yet since you dont have an airfilter yet. hope it runs great but i'd still replace the chain and tensioner.

I got my RM250 air filter on the thing. it fit right on there!!! the cages are almost identical except the dumb screen. I started it and low and behold it spit out a lot of oil out one of the cavities for the oil filter. So I took out the damaged oring and put in 2 good ones. So I have to start it since because its that time of day when ppl in the community are out. So later like 1 or 130 ill restart and see whats up. other than it started, ran I just didnt get to ride it

Hey, Luigic81!!!

Is this shift stopper that little spring loaded arm that has a roller bearing that sorta indexes the shift drum? :banana:

My ridin' buddy has an '03 or '04 (steel frame) YZ250 2-stroker. That part I attempted to describe above had the roller bearing come apart, and went all through his tranny, wreaking much havoc..... ;) It took out several gears, a shift fork, & such..... It scares me to think of what it could do to one of our bikes...... :eek: This is the first I've read of such deal on the big thumpers..... Would anyone have a part number for the updated part?

Jimmie

new part # 2S2-18140-10-00

Thanks, Luigic81!!! ;):banana:

Sorry about the thread hijack, asg5265! :lol: Glad you got your bike to run, and it's nice to know about the RM filter fitting..... :eek:

Jimmie

so now its popping and not responding to idle adjustments barely. OH JEEZ! I want to think its jetting because the motor does not like to wind down and has a hanging idle. Im thinking spark plug, fuel screw that has no oring, or a loose jet the pilot that is. I will investigate after I get fresh gas and a new fuel screw.

Whats the current jetting?

...and it's nice to know about the RM filter fitting..... :banana:

Jimmie

At one point I had an '02 YZ426, '02 YZ250, '03 RM250, and an '06 YZ450 and they all used the same air filters. Just one of those little things that makes life just a little bit more simple. :eek:

The chain guides were all interchangeable also if I recall correctly.

Good question, these bikes are also notorioiusly lean from the factory. I'm at sea level and its been about 80-85 degrees here, I'm running 165 main, 48 pilot, stock needle position, FS about 1.5 turns out, ap timing screw is wired, also had to turn it CCW about 3/4 of a turn to get rid of bog, stock leak jet

42 pilot, cant remember the main, I think its 168, my 250f just started making another noise last night...Im almost done doing the work myself

42 pilot, cant remember the main, I think its 168, my 250f just started making another noise last night...Im almost done doing the work myself

put a 48 pilot in, and start around 1.5-2 turns out on the fuel screw, your popping problem should be fixed.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now