Sign in to follow this  
Followers 0
BigMike

Magura Hymec Hydraulic Clutch.

14 posts in this topic

Anybody out there using the hydraulic clutch

set up on their yz426? I have been thinking about setting mine up with one to reduce clutch pull and to capitalize on its self adjustment.

Share this post


Link to post
Share on other sites

I am interested in this also, I have riden a friends ktm400sx which has a wet clutch and is a single finger operation.. liked it a lot!!

How much does a kit like this cost?

Share this post


Link to post
Share on other sites

I'm using a Magura Billitanium on my 250F and it is REALLY nice!! No more adjusting the clutch and it's a little easier pull. Not a

one finger pull but nice and consistent.

Share this post


Link to post
Share on other sites

i've got one o my WZ. it's brilliant.

the big difference?

well i would ride around slimy rocks & logs & i had to pull the lever in originally with all four fingers.

but you can't hold a bike with your thumb!!!

so i'd try & use the throttle to get out of trouble. you just can't. it's a bl*** waste of time.

now i feather the clutch with two fingers on the bar & two on the lever.

with the flywheel weight i use no throttle at all & can chug anywhere.

not the best value per £ spent but you can't knock the quality & the improvement it makes.

BTW. i broke the clamp on me hols & couldn't get one. just walk in your katoom dealer & order it there in black (they come gunmetal).

see KTM's are good for something! now where's my fishing rod...

Taffy

Share this post


Link to post
Share on other sites

Hymec goes for 269.95 for the yz426

Originally posted by needathumper_:

How much does a complete hydrolic kit go for?

Share this post


Link to post
Share on other sites

I put a Magura hydraulic clutch setup on my '01 426 and couldn't be happier. Probably the best upgrade I've done (so far). I really didn't like having to readjust the clutch play and once it cost me decent start in a race (pulled me into the gate as I reved the bike at the 5 second mark because I'd forgotten to adjust it prior to lining up). Now I've completely forgotten about it. No more adjustments, super smooth feel. Not a lighter feel but very smooth and progressive. Installation was very simple and I've had no problems since (3 months).

I pulled the rubber 'booty' off the stock clutch cable to protect plunger better from dirt (should have been stock) and added some tape to enhance the protection. Other than that it's been fine. Pretty pricey but very nice.

Share this post


Link to post
Share on other sites

I put one on my 99 400 and the problem that I've had is when I turn the front wheel all the way to the right it wants to put my decompression lever in enough to kill the bike. Happened this weekend in springfield during an arenacross race. Did you leave your original decompression lever on?

Yelyz400

Share this post


Link to post
Share on other sites
Originally posted by blbainb:

I put a Magura hydraulic clutch setup on my '01 426 and couldn't be happier. Probably the best upgrade I've done (so far). I really didn't like having to readjust the clutch play and once it cost me decent start in a race (pulled me into the gate as I reved the bike at the 5 second mark because I'd forgotten to adjust it prior to lining up). Now I've completely forgotten about it. No more adjustments, super smooth feel. Not a lighter feel but very smooth and progressive. Installation was very simple and I've had no problems since (3 months).

I pulled the rubber 'booty' off the stock clutch cable to protect plunger better from dirt (should have been stock) and added some tape to enhance the protection. Other than that it's been fine. Pretty pricey but very nice.

Share this post


Link to post
Share on other sites

I put a Hebo clutch on my YZ400 and ran into the problem of the compression release getting too tight when I turned to the left so I mounted it with the lever below the handlebar. Made the difference.

Pat

99 YZ400

Share this post


Link to post
Share on other sites

Solving the decomp. problem is easy....

Just re-route the dcomp. cable.

Mine works as a charm :)

I know I have said this before, but if You are planning to get a Magura clutch beware that You get the latest model with the Aluminium slave cylinder head cap.

The old style with plastic caps is no good!!

Hope this helps, Numpsy

Share this post


Link to post
Share on other sites

numsey

I have tried rerouting the cable and it still does it. which route did you take with the cable I need help with this.

Yelyz400

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0