HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
wrterry

2000 wr400 seal problem

2 posts in this topic

Hi all im new to the site

I have a wr400 2000 and im experiencing the usual leak from the weep hole on the water pump.

i have all te relevant parts now to fix problem.

my question is does anyone know the correct way round the two seals sit?

I have a manual but its not 100% accurate on the right way round they sit. im pretty sure the indent side with the spring round it sits facing away from the engine and then the other side sits facing into the engine if that makes sense!?!.

you guys might say refit as u take out BUT the seal markings are facing outwards as i removed the impellar thus the leak im experiencing maybe?

if anyone could shed some light that would be grand!!! thanks in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0