2088 YZ450F motor bogging

I have had a 2008 YZ450f since it was new. The bike developed a killer bog while under throttle during the last ride. I pulled the carb and cleaned it. Pulled exhaust pipe. Disconnected the throttle position sensor, and kill switch. I also took the air filter completely off. All of these changes had no effect. The motor will start within one or two kicks. Then rev cleanly to almost 1/2 throttle. Then it falls on it's face so bad it will kill the motor. The jetting is the same as I have run since the last rebuild. Nothing found in the carb. The bike sounds way too rich but removing the air filter has no effect. Has anyone had ignition box or stator problems with these bikes?

If it's really too rich, you might want to see if the main jet fell out. OTOH, you could be wrong, the bike could be lean due to a blockage in the jet.

Yup...I was gonna say that its a main jet issue. I would take the carb back apart and recheck. If it isnt that, then its likely electrical.

Damn your bike must be trick!!! But how did you get is 78 years early? Time machine?

:thumbsup:

it starts within 1 or 2 kicks, but is it harder to kick over?

Spark issue...replace stator.

Damn your bike must be trick!!! But how did you get is 78 years early? Time machine?

:thumbsup:

And their still using carbs. That disappoints me.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now