I Can't Figure This Out.....Need Help Please

I've gone to a 200maj,160mj,40pilot,85pilot air jet, 1.5 turns out, and an EKQ needle(3 from top). I ride at 4,000 to 7,000' temp varies from 10c to high 20's. My mod are in the signature below. When i start the bike on choke it revs to the moon, shut the choke off it dies. I can't get the idle right no matter what i try. I'm also incurring a lot of back fire even while attempting to idle. I've had a shop do the work and I'm wondering if they screwed up when doing the YZ timing :). Help me out brothers please.

Chuck

Chuck,

Its a riding day, so the real WR responses with your bike should be back at the keyboard tonight. Just some basics, before you spend a dime. Verify your valve clearances, make sure your carb is clean, properly mounted and cables are operating as they should. I would consider the checking the flywheel key to make sure it's not been sheared. Start with a properly gapped spark plug. Now you should be able to trouble shoot.

If you can wait a day or so, a helpful 426 rider can probably solve this quicker.

rode it they way it is today. hope i didn't kill it :)

I would take the valve cover off and double-check their work on the timing change. Easy to screw up (especially for a shop that probably doesn't require their mechanics to read ThumperTalk!). Not much work for the peace of mind and SOMETHING is definitely wacky!

The backfiring really makes me suspicious of this. If it is backfiring through the carb, it means the intake valves are still open at the instant of ignition. That is a function of timing. And yours was just changed prior to the problem...

Let us know what you see under that valve cover...

Thanks all for the responses, will check tonight :)

Did the shop have your carb' slide out?.........

shop went the wrong way on the timing(retarded it) and put the carb slide in backwards :)

shop went the wrong way on the timing(retarded it) and put the carb slide in backwards

And I bet they only charged you $65.00 an hour to do it.

Waddya complaining about? :)

hope you get it fixed!

At least the Yamaha shops are consistent in the US and Canada. They don't know anything here either.

At least the Yamaha shops are consistent in the US and Canada. They don't know anything here either.

LMAO add portugal to the list please :)

Good to see they don't do things by halves :). Screwed up your timing AND put the slide in backwards! They should fix it, and give you something for your trouble (grips or something) to restore a little faith in them.

Makes me appreciate my dealer all the more then i guess.....

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now