HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Nitrousman

2005 YZ450 only runs with choke on?

13 posts in this topic

I looked at a YZ 450 tonight that appears to be in really good shape but for some reason it really didn't want to run unless the choke was on. The owner said the bike has sat since last July without being run but that it had Stabil in the gas when it was parked. Has fresh gas in it now but it still only runs with the choke on. Now it was about 35 degrees out so I'm wondering if that had something to do with it? I really can't beat it for the price but I don't want to have a major issue trying to get it running correctly. Could it just be the temperature now or maybe the carb just needs a cleaning? Thanks for any help.

Share this post


Link to post
Share on other sites
I looked at a YZ 450 tonight that appears to be in really good shape but for some reason it really didn't want to run unless the choke was on. The owner said the bike has sat since last July without being run but that it had Stabil in the gas when it was parked. Has fresh gas in it now but it still only runs with the choke on. Now it was about 35 degrees out so I'm wondering if that had something to do with it? I really can't beat it for the price but I don't want to have a major issue trying to get it running correctly. Could it just be the temperature now or maybe the carb just needs a cleaning? Thanks for any help.

clean the carb and pay extra attention to the pilot circuit.

Share this post


Link to post
Share on other sites

I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck

Share this post


Link to post
Share on other sites
I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck

Were the valves out of adjustment or not sealing properly?:thumbsup:

Share this post


Link to post
Share on other sites
Were the valves out of adjustment or not sealing properly?:thumbsup:

What he said? Just the valve lash or did it need a complete valve job?

Share this post


Link to post
Share on other sites
I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck

This simply doesn't make any sense.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0