WR426 lighting problems

Hi guys, I have a 2002 WR426. I decided to add a battery in order to connect lights, horn, fan, etc for dual sport purposes. I followed a diagram from internet. I used the stock voltage regulator but I added a rectifier to get DC power. I did all the connections and now the battery is not getting charged. I opened my WR manual and first checked the lighting coil. I have a cheap electrical tester but I got a reading of less than 0.1 Ohm ( normal values 0.16-0.24 Ohm). After that I considered that the coil was good and I try to check the regulator and I got a really low voltage from it ( 4-8 volt revving the motor to 4000-5000). Then I took out and regulator/rectifier from my XR400 that looks like the one that Baja Designs sell. I connected it and got the same voltage readings so I guess the problem can be something with the lighting coil or something with the ground (negative) connection.

Lights were working perfectly before I decided to make the additions.

Is there any other way to check the lighting coil to be absolutely sure of it function?

If I did any wrong connection that could fried the lighting coil?

What about the ground connection, where should I connect it?

I need some specialist advice !!!!! please help!!!!:ride:

THANKS IN ADVANCE!!!! :thumbsup:

Is there any other way to check the lighting coil to be absolutely sure of it function?

You may want to disconnect the voltage regulator, set your tester to Vac and test the lighting coil directly. Disconnect the stator connector from the harness and attach you tester leads to black and yellow wires coming from your stator (or two yellow wires if you have floated the ground) and measure the voltage at idle RPM. Should read about 15V.

If I did any wrong connection that could fried the lighting coil?

No.

What about the ground connection, where should I connect it?

The black lead from the stator or frame bolts (stock stator, without the mod). When you are converting your bike to DC, it's recommended to do the "Floating the Ground" stator mod and use an aftermarket voltage regulator-rectifier for best results.

TrailTech 150 watt full wave regulator/rectifier:

http://www.trailtech.net/7003-RR150.html

BajaDesigns 160 watt full wave regulator/rectifier:

http://www.bajadesigns.com/NET/P-122003/Regulator%2frectifier%2c+(dc)+(unwired)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now