HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
The Hill Boys

What year(s) YZF450 exhaust will work on 06 WR450F

20 posts in this topic

Thank you. I've been searching and that seemed to be the conclusion. I saw somewhere where 03-05 would work.

There was an 07 exhaust on Craigslist here for $20. I was really hoping it would work. Oh well.

Thanks!

Share this post


Link to post
Share on other sites

03 to 05 YZ450 silencer

It will make it a completely totally 100% different bike. For the better. It will feel like it blew its nose. So much more fun to ride

I was going to sell my bike until I put the pipe on.

Get a YZ exhaust cam too.Even if you are slow. These are full on race motors. They dont run well detuned

Share this post


Link to post
Share on other sites

can you run the stock 06 header pipe with the 03-05 yz silencer? did you need to rejet?

thanks

Mike

Share this post


Link to post
Share on other sites

So, I picked up an FMF exhaust from an 03 WR450F. The mid pipe touches the shock reservoir. The guy I bought it from was super cool and said that I could bring it back for a refund. So, I assumed that since an 03-05 YZ exhaust would work, so would a 03 WR. Am I missing something here? My stock mid pipe as a couple of angles in it to go down and under the reservoir then back up. The 03 FMF is straight. Is this just a "feature" of the 06?

Share this post


Link to post
Share on other sites

Found a stock 2003 YZ450F exhaust. Backfires really bad now. Was running perfect before. Here is what I had it set to:

165 main, JD Red #5, 48 Pilot, 1.25 turns, 68 starter jet, #50 leak jet. I also bought an MSR fuel screw.

What adjustment is needed to control the backfire?

Thanks!

Share this post


Link to post
Share on other sites
Found a stock 2003 YZ450F exhaust. Backfires really bad now. Was running perfect before. Here is what I had it set to:

165 main, JD Red #5, 48 Pilot, 1.25 turns, 68 starter jet, #50 leak jet. I also bought an MSR fuel screw.

What adjustment is needed to control the backfire?

Thanks!

The backfiring/popping could be many things.

Is the AIS disabled or blocked? If not that fresh air its pumping into the exhaust is burning off unburnt hydrocarbons causing a "pop" sound on decel.

Putting a wide open exhaust on it leaned out the mixture. At the minimum you'll have to turn the fuel screw out.

If the AIS is disabled or blocked off and the jetting is spot on then you have a leak at the header/midpipe junction.

Share this post


Link to post
Share on other sites
The backfiring/popping could be many things.

Is the AIS disabled or blocked? If not that fresh air its pumping into the exhaust is burning off unburnt hydrocarbons causing a "pop" sound on decel.

Putting a wide open exhaust on it leaned out the mixture. At the minimum you'll have to turn the fuel screw out.

If the AIS is disabled or blocked off and the jetting is spot on then you have a leak at the header/midpipe junction.

The AIS has been disabled with the GYTR kit. Basically did all the "free mods". Proir to adding the YZ450F exhaust, it ran perfect.

I'm going to play with it some more tomorrow. If I recall, it was backfiring also with the choke on, so I'm leaning towards the header/midpipe leak.

Share this post


Link to post
Share on other sites

:thumbsup::banghead::lol:

The mid-pipe gasket from the YZ450F seemed a little tired so I pulled the one off my stock WR exhaust. Made sure the header and mid-pipe clamps were tight. Still backfiring (popping) very badly when throttle is closed. Tried backing out the fuel screw. My rev went up as I back it out, but the popping was still there. After a little more researching, I decided to change my main jet up to a 168. I know that's not supposed to help, but I haven't really seen any references to anyone using a #50 pilot. In doing so, I realized that my clamps on the front side of my carb were not tight. I was really hoping that was the problem. Put in the 168, made sure carb clamps were tight, backed fuel screw out to 1.5 turns. Still popping. I'm going to let things cool down and put the stock exhaust back on. If things are fine, then should I go to a #50 pilot?

Share this post


Link to post
Share on other sites

The pilot may be clogged? It may not even be dirt but gummed up fuel residue. Some of these new fuel blends the government is mandating work well in pressurized FI setups (while the gas is still reasonably fresh) but go to shit in a hurry on a carb'd intake setup.

The only time I remember anyone running a 50 pj in a WR was in a dirtbike magazine article in '06. Their fuel screw setting was "slightly less than a turn out" It wouldn't hurt to try it but I'm not sure its gonna need a 50 pj.

Share this post


Link to post
Share on other sites

I went ahead and put the #50 pilot in. Still popping. Prior to this, I went ahead and put the almost stock (pea shooter/end pipe removed) WR exhaust back on. I didn't pop. However, I could hear what sounded like would have been popping but it was muffled so not apparent. I was riding down the street without a helmet so I could hear things a lot better.

I've seen in the Intake forum where Eddie says popping is normal to some extent. The bike runs fine. I would like to not hear the popping, but was more concerned that it was a lean condition and that I may be harming the bike. I may just stick with the stock exhaust. The bike sure felt more "torquey" with the YZ exhaust.

Share this post


Link to post
Share on other sites

Well, I thought I found the problem. I took the header pipe off and there was no gasket! Ran up and picked one up. Installed it and since I was sure this was the problem, reinstalled the #48 pilot. Still popping very loadly on decel/shift changes. I'm going to take it out for a longer ride this weekend and see what happens fully heated up. May keep the YZ exhaust on and live with the popping or put the stocker back on. I was really hoping this would be the end of it.

Of note, I have a 2003 YZ250 (2 stroke) that I have owned for three years. I have never messed with the jetting once. I always heard 2 strokes were more sensative.

Share this post


Link to post
Share on other sites

That is not a back fire it is just decel popping, wont hurt anything, check your plug color make sure it's not too light.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0