HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
jbodin18

Issue with 04 YZ450F

1 post in this topic

Hi guys. I'm going to try my best to describe my bike problem. While riding the bike, about 1/4 to mid throttle, the bike starts to feel like its reving more than its actually putting out. It wasn't happening at the beginning of the ride, but by the end was obvious the bike wasn't running properly. Could it be the clutch plates slipping? It's my only guess at this point. Clutch doesn't seem to have problems when its engaged. Problem only seems to exist when twisting throttle.

BTW, I've had my bike since 05, and put tons of hard hours on it, and never had to do anything to the motor other than adjust the valves (twice since I've owned it) and adjust the carb. Any help would be appreciated. I don't want to fork out the coin for a new clutch kit if I don't need to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0