Starter Question

First off, my starter works perfectly fine but the last few times I went riding (2 monthes ago or more) when I pushed the button there would be a 50/50 chance of it doing nothing. When nothing would happen, all I had to do was slightly engage my kick start then it would turn over. I went to start it yesterday and it would not do anything...and yes the battery has a full charge. I also had a YFZ 450 that did this too but ended up selling it before I got it fixed so I'm guessing it's a common problem. However, I searched it and there was nothing related to this. The only thing I found that may be usefull is some guys say to grease the starter shaft and I'm not quite sure how this is done. BTW my bike is an '04.

I would first try a different button on the bar. Mot of the Yamaha's, you can swap the kill for the E start button. If the problem goes away, that is it. Next might be the starter relay though these rarely fail. Only way to test it is to swap in a known good one. Next would be a damaged starter armature. To have this checked (and fixed, if possible) you'll need to take it to an auto electric shop and have them test it on the growler.

I have a 09 wr450 it doesn't do it all the time but occasionally does,i think its just up on the compression stroke,which is not allowing it to start of the button i just give it a little rock in gear then hit the button.

I have a 09 wr450 it doesn't do it all the time but occasionally does,i think its just up on the compression stroke,which is not allowing it to start of the button i just give it a little rock in gear then hit the button.

that is exactly what my 06 does at time....

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now