junk in oil filter

just cleaned my re-usable oil filter after about 8 hours of run time. i found a bunch of differnt kinds of material come out... brown bits, black bits, and even a little bit of metal glitter. this cant be normal, can it?

i bought the bike new and it only has a total of 14 hours on it.

Yes it can be normal for the metal shavings on a new bike to be in the oil filter. This is one reason I use the paper filters for the first few hrs on a new bike, then swap over to my Scotts. 8 hrs - please tell me you got at least 2 oil changes in this time? 14hrs seems excessive unless you were real easy on it the first 12hrs to be getting junk in the filter

The black - did you by chance ride in a deep mud puddle or stream?

Yes it can be normal for the metal shavings on a new bike to be in the oil filter. This is one reason I use the paper filters for the first few hrs on a new bike, then swap over to my Scotts. 8 hrs - please tell me you got at least 2 oil changes in this time? 14hrs seems excessive unless you were real easy on it the first 12hrs to be getting junk in the filter

The black - did you by chance ride in a deep mud puddle or stream?

this was my 4th oil change but only the second time cleaning the filter. i only had the stock paper filter in for about an hour, then switched over to the steel.

i dont recall going threw any streams or deep mud puddle. could it be clutch material?

Most likely yes, clutch material and completely normal. Unless there was A LOT of it, I wouldn't lose any sleep.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now