HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
cbesing

Help - Oil Problem

2 posts in this topic

Last ride noticed oil very dirty after one ride. Almost a silver/metallic look

Came home changed oil and started and did 4 heat cycles...no clutch

Oil very dark and either bubbles od metallic look. let sit and just turned dark.

Drained oil again, refilled and aran one heat cycle. again dark but not as dark..same metallic look at first then just kind of dark green.

Very worried!!!

Share this post


Link to post
Share on other sites

BTW, just read some previous posts on the same issue. I drained the oil per the prodedure listed here. I did three successive oil changes...same problem...dark metallic look....low viscosity. poured oil into glass jar and let settle...still looks like it has very fine metallic particles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0