does a yz cdi run a wr 400?

hi, im in the process of converting my wr 400 to yz timing and wondered if the yz cdi will run the wr without any other mods? can anyone help or has anyone done this mod already? i have changed the cam timing to yz and wanted to go the full hog with the cdi aswell if it works.

No, stators are different. Instead of trying to make a YZ CDI work, get an aftermarket WR one with mulitiple maps.

what sort of engine response would this make? more power in mid range or just more response off the throttle? im looking for more response off the throttle not bothered about top end just want it more snappy. do you know where i can get an after market wr cdi?

Simply removing the Grey wire kicks up the response to be'more yz like'. But a CDI by itself is not pure magic. Cam timing, carb jetting, exhaust system all affect throttle response.

Vortex and DynaTek both make reputable units. Hope you have money.

Jetting jetting jetting

i dont know much about jetting so how does it work the bigger the jet the more fuel goes through but how do you know what jet you need?

hi, im in the process of converting my wr 400 to yz timing and wondered if the yz cdi will run the wr without any other mods? can anyone help or has anyone done this mod already? i have changed the cam timing to yz and wanted to go the full hog with the cdi aswell if it works.
what sort of engine response would this make? more power in mid range or just more response off the throttle? im looking for more response off the throttle not bothered about top end just want it more snappy. do you know where i can get an after market wr cdi?
i dont know much about jetting so how does it work the bigger the jet the more fuel goes through but how do you know what jet you need?

The FAQ's in the stickies at the top of the wr400/426/450 forums will tell you about the Accelerator Pump and how to tune / mod it so that you don't get that "off-idle bog"... is that the problem you were looking to fix? If I misunderstood then I'm sorry, I didn't mean to sound like a smart-arse. :banghead:

yes this it the problem! ill have a look in the faq's to see if i can sort this problem.

Glad I could help :banghead:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now