2006 WR 450 thoughts...

Definitely try the 13 t counter sprocket, you'll love it.

got my sprocket in today....hopefully we get to ride this weekend, will report.

jay

I also have had great luck with turning up the idle, LOL, you will know it is just about high enough when it is forcing you into the downhill switchback turns too fast after you start riding down the hill you just climbed:banghead:

Just got an '06 this year and had similar problems stalling until I turned up the idle speed and adjusted the clutch to disengage sooner.

Another thing that helped was drilling another hole in the lever to position the cable end closer to the pivot point. That made the clutch pull easier and reduced arm fatigue.

http://www.thumpertalk.com/forum/showthread.php?t=599598

Just got an '06 this year and had similar problems stalling until I turned up the idle speed and adjusted the clutch to disengage sooner.

Another thing that helped was drilling another hole in the lever to position the cable end closer to the pivot point. That made the clutch pull easier and reduced arm fatigue.

http://www.thumpertalk.com/forum/showthread.php?t=599598

I did that same mod and I love it:thumbsup:

There was a lot of complaining in that thread about broken clutch cables. I believe the reason for that is because some people did not take the time to file and detail the cable grove inside the lever after drilling the new piviot point. I spent a lot of time on it (about an hour) and even checked the adjuster bolt hole edges where the cable comes out. The stock cable adjuster is pretty clean where the cable exits the adjuster.

Lubed the cable while I was at it!!:excuseme:

Now my clutch pull is eaiser than my kids YZ85 and he has a new cable. it is so sweet.:bonk:

did thr 13th front and picked the idle up just a tad... bingo...

only stalled once and it was a bad place and got hung up on a rock on the rear chain guide... i can live with that...

now to figure out what i did to the estart... got it stuck last ride and really got the estart hot.. now it sounds like a bushing is out... squealing bad...

any thoughts..

thanks for all the input.... it was a great ride, even kickstarting it..

jay

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now