06 450 clutch is creaping

I have an 06 yz450 that the clutch will creap until I crack the trottle a little and it will free up. I have adj. clutch cable ,inspected the clutch plates , I change the oil every 4 hrs, the only thing I've done different was to change to a new oil (ester base). I just now change the oil again but with a petro. base and still have the same problem. I've owned this bike for 3 year this a first. I also have set the idle. has anyone had a simular problem. thanks, jik

Make sure you check the metals and not just the plates , it doesn't take much to make them lurch forward. Also if thats the original clutch , might be time to replace anyhow....good luck

The basket may be getting a little notched also. If and when you do put a new basket and plates and springs in you can get a little longer service out of the clutch by replaceing the springs in it every so often.

This applies a little more grab action to the plates when the the clutch is engaged.

thanks guys, but I went and rode about 50 miles this morning with the petro base in and after about 10 miles it started working like a champ. I guess the clutches don't like the other stuff.

thanks guys, but I went and rode about 50 miles this morning with the petro base in and after about 10 miles it started working like a champ. I guess the clutches don't like the other stuff.
It isn't true in every case with every conceivable oil, but in general, with a YZF, if you have a clutch problem that can be "cured" by switching oils, switching oils did not really cure the problem, it just covered it up.

good to know

thanks, jik

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now