OMG Unabiker!!!!! Big RANT!!!! Rant Withdrawn

HOLY MOTHER OF CR@P!!!

WHAT A LOAD OF SH1T! THERES NOW WAY IN HELL THESE FIT WITH OUT SEVERE DREMELING AND BRUTE FORCE WITH HAMMER!!

I live in a 3rd world country, I am resigned to the fact of inferior products and service..but never have a experienced such way out manufacturing!!!

If I wanted to exact revenge on my children's killers I would task him with fitting these BS guards!!!!!!!!!!!!

And don't ask me why I don't just send them back, I live in Africa, thats $40 dollars and 3 weeks one way!! and my bike is half dismantled with them half on!!!!:busted::banana: :banana: :busted: :busted: :banana: :banana: :busted::D:lol: :lol: :lol:

Ok, I apologize to Unabiker for the above. I have fitted them, and the actual quality of product seems plenty solid. Took some dremmeling, a long time, with several deep breaths and explicitives!

Perhaps some more detailed instructions would help I think.

On a side

Sorry about your luck, I have bought them for 2 different bikes and have never has an issue...yes they are a "tight fit" but once they are, you will NEVER have to take them off :busted:

Sorry about your luck, I have bought them for 2 different bikes and have never has an issue...yes they are a "tight fit" but once they are, you will NEVER have to take them off :busted:

+1.

I've bought them for two different bikes (yz & wr) and both fit fine. They are a tight fit and it's important to follow the installation instructions step by step, as they are like a puzzle that can only be put together in one specific sequence. The first time I installed them it took quite a while, but it wasn't impossible, then the second time it took less time & was easier. Might have been just a random manufacturing defect.

Have followed instructions, all bolts still loose, bike 08 and never dropped.

Theres no chance this set bolts on with out re engineering!

Maybe you can be a little more specific, what part exactly is not fitting and what year WR is it going on? I also have them on an '08, with the only issue being that I needed longer bolts and spacers to attach the radiator shrouds to them.

I missed something here..What are you talking about exactly?

I have them on an '03 and they fit perfectly. VERY tight fit, but perfect. If you have mangled up radiators, they are not going to fit. I installed the guards and a new set of mylers radiators at the same time. It took some muscle but I have had them off since and they go on and off easily after the first installation.

Dropped my bike hard on the right side with them on. ZERO damage.

With the exception of the bottom bolt on the left side being too short, the unabikers fit perfectly on my bike. In all fairness I bent the radiator tab in a previous wreck and didn't get it completely straight.

I bet you are referring to the inside side plate... I had to look at it 15 different times before I said... "oh, that's the way it goes!" It was on my 07' so it's the same as yours... I can't remember exactly how I was trying to mount it wrong but it was the inside side plates (the pieces right next to the frame that I kept saying to myself... "self... these are for another bike" but persistence paid off and after a few flipping around and over of the pieces and trying different ways it finally was apparent.

Try an e-mail to UNABIKER if you are 100% sure.

I bet you are referring to the inside side plate... I had to look at it 15 different times before I said... "oh, that's the way it goes!" It was on my 07' so it's the same as yours... I can't remember exactly how I was trying to mount it wrong but it was the inside side plates (the pieces right next to the frame that I kept saying to myself... "self... these are for another bike" but persistence paid off and after a few flipping around and over of the pieces and trying different ways it finally was apparent.

Try an e-mail to UNABIKER if you are 100% sure.

True. Assuming he has not received the wrong kit, you really have to pay close attention to where the rods mount in the diagram. Where the rods mount across the back of the radiator to the interior side plates and where the crossover rods mount between the two radiators. I still have my instructions somewhere, but I remember there were different lengths in the rods as well.

I remember that it was key to follow the directions step by step, since some of the bolts had to be tightened on a specific sequence. The hardest ones were the ones that go between the two radiators, space is limited there. It really helps to have some long t-handles in order to reach the inside bolts. The first time I installed a set it did cross my mind a couple of times that something was wrong, but it was all ok.

I went with the Bullet Proof Designs due to the ease of install. $100 more but had both sides on in 20min. Hope it works out for you, they look like a very nice product.

I remember they were a tight fit. I also remember improvising on the instructions somewhat. I think I loosened the rads to let them float but didn't remove them.

But all the holes lined up. Only change I made was a bigger spacers and longer bolts on the lower shroud mounts.

Well if it is any comfort, I went with Fastway and while installing the left side guard I thought seriously about taking a sledge hammer to the entire bike and then lighting it on fire and throwing it off a cliff. The right side guard pretty much installed itself.

yeah, I have them on two bikes also... my DRZ400 and my WR450... like everyone said.. its a tight fit.... but the other question is.... how old is your bike and how long have you been riding without guards on... its probably not the unabiker guards.....your radiators may just be tweeked.....

but the other question is.... how old is your bike and how long have you been riding without guards on... its probably not the unabiker guards.....your radiators may just be tweeked.....

To a point I would agree but at the same time, I installed my rad guards on a brand new 08 never started and it was still a TIGHT fit :busted:

PA250026.jpg

To a point I would agree but at the same time, I installed my rad guards on a brand new 08 never started and it was still a TIGHT fit :busted:

PA250026.jpg

I installed them on mine and it was tight too... but not impossible...... i think the worst part was trying to reach all the allen head screws... i went out and bought a super long extension

I went with the Bullet Proof Designs due to the ease of install. $100 more but had both sides on in 20min. Hope it works out for you, they look like a very nice product.

Can you post a picture?

IMG_0320.JPG

IMG_0432.JPG

Those are cool ! thanks.

Do they only support (mount) on the radiator mount bolts or do they have support/mounting brace on the rear?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now