Decompression Plug

i have a 2003 yz450f today i lost the plug when riding is this common

Yes, the TT store sells a billet one that does a better job of staying put.

Yes. Check you breather tube. Be sure it's not pinched or obstructed.

http://www.thumpertalk.com/forum/showthread.php?p=1522419#post1522419

For a better solution than the original, PM TT member Vibeguy

or save yourself the extra coin, get a new stock one for $3, put a good adhesive sealer on it, drive it back into place and with a punch stake it in place....it won't go anywhere and it will save you a 20 spot....unless you gotta have bling then by all means, get the billit one, since you can't see it buried under your tank and behind the radiator....:busted:

or save yourself the extra coin, get a new stock one for $3, put a good adhesive sealer on it, drive it back into place and with a punch stake it in place....it won't go anywhere and it will save you a 20 spot....unless you gotta have bling then by all means, get the billit one, since you can't see it buried under your tank and behind the radiator....:busted:
It isn't about bling, it's about function. The OEM plug is nearly useless, regardless of what it's sealed with. The billet plug is a simple, highly effective, but not inexpensive solution.

Personally, I use an 18mm cup plug (read, freeze plug) from an auto parts store for $1.50. Harder to install, but very effective.

i am going to get 2 plugs today to fix it now and have a spare as most of my riding is in the desert will also get the billet and change it latter

my breather was a little pinched found it on one my breaks from pushing my bike to call the wife to come get me no service

this happened on a high speed long run down a dirt

May be it's the way you install it gray....I have done it many times with not one issue... anyway you slice it, you gotta do what you do...Sorry you cant make the OEM item work, but it sounds like the $1.50 freeze plug works for ya....

I'll keep installing the stock unit until I have an issue....

OK i got the stock plug installed and the oil changed was looking for the plug on the TT store and did not see it am I overlooking it or what?

the stock plug is kind of weak looking but goes in easy so keeping a spare on you should not be a problem

#15 at the bottom of the camshaft/chain page.

Bear in mind that you may not know immediately when the plug decides to bail out, and while it is gone, your engine is open to all the lovely elements you ride in.

OK i got the stock plug installed and the oil changed was looking for the plug on the TT store and did not see it am I overlooking it or what?

the stock plug is kind of weak looking but goes in easy so keeping a spare on you should not be a problem

This is what gray was talking about...they are weak and they go in easy, which means they come out just as easy....Hence a good adhesive and staking it in place with a punch and hammer.... I tend to make what I have work and not spend extra money (yes, I am a cheap ass bastard) so I find ways of improving on an Item that is poorly designed in the first place...

I will agree with Gray that the aluminum plug is a good item for someone that wants to fix the problem once and for all and not ever think about it again...Like I said though, i have installed many of the stockers, glue them in then stake the metal of the head around it.....I have never had a problem after replacing the original that gets puked out...

Gray, I was giving you grief and just poking at ya, hope you took it as such...:busted:

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now