HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
bcs

Cycra hand guard problem

8 posts in this topic

Installed a Scotts steering stabilizer, a BRP sub mount. Also installed new Pro Taper "countour" handlebars today, in the Henry/Reed bend--almost identical shape to the stockers. Then I tried to install cycra probend hand guards. I think maybe I got the wrong parts, 'cause when I tried to fit one on, loosely, it looked like this:

DSCN0882.jpg

Does this look right? I know sometimes you have to bend the guards a bit, but this is too much.

The hanguards are cycra probend (not the CRM) and the U-clamps are p/n 1150-02. I have the U-clamps on the bar loosely. They are tapered and fit OK where you see 'em, but for the length of the hand guards they need to be about 2" closer to the handlebar mounts.

I'm thinking the guys at the shop gave me the wrong clamps. Or am I going about it wrong? Thanks.

Share this post


Link to post
Share on other sites

I have the same setup on my contour CR HI's. mine are closer to the sub mount, they cover the r in "contour" maybe try mounting the clamp on the other side.

Share this post


Link to post
Share on other sites
I have the same setup on my contour CR HI's. mine are closer to the sub mount, they cover the r in "contour" maybe try mounting the clamp on the other side.

Mine cover the "r" as well.

Share this post


Link to post
Share on other sites

Dude,

I had the EXACT same problem with mine on my all stock 09. In the end, instead of trying to return stuff and what not I simply cut about 1 and 1/2 inches off the inside portion of the Cycra guard, drilled a new hole and used a BFH and my vise to bend it just a bit to fit.

Sucked to have to do ANY mods to a $100 item to get it to fit but in the end it looks fine and works great.

Share this post


Link to post
Share on other sites

I don't have that handlebar so I can't say for sure, but it looks like you need to slide those U-clamps way closer to the handlebar mount, way down on the bend, those clamps will adjust to the bend. Looks like you have plenty of room to slide them down too. It seems awkard at first, but once you tighten them up they will fit good. If it still doesn't work, then you have the wrong mounts.

Share this post


Link to post
Share on other sites

If the clamps are like mine, they will not slide down and fit properly becasue the taper of the handlebar is different so only the very edge of the clamp touches the bar in that lower position.

Share this post


Link to post
Share on other sites
I have the same setup on my contour CR HI's. mine are closer to the sub mount, they cover the r in "contour" maybe try mounting the clamp on the other side.

+1, mine were marked right and left.

Share this post


Link to post
Share on other sites

Oh what a difference the correct part makes. The guys at the shop set me up with the right U-clamp today. Now it fits together the way it should, without any bending, cutting, etc. Looks like this:

DSCN0885.jpg

For those of you who may go down the same path, the correct part number for the Cycra U-clamp is 1156-02. They are stamped "KTM" but if you read the cycra catalog they are described as fitting 08 pro tapers.

OK, OK, I know this is a boring thread, but since I started it I figured I should at least share the answer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0