450 street legal wiring.

I bought a baja designs signal switch. I am having an issue with the signals they all stay lit up and dont flash. I have a 2 pole flasher I bought from the thumpertalk store power goes to flasher then into the wire labeled on the flasher. My battery is toast in my bike I have heard that might be part of the problem. Can someone offer some help please...

If you are using led flasher bulbs, they may not draw enough current to cause the flasher to "blink". If that is the case you can install some emulators from autozone.

Try this, hook up a "regular" old 1157 bulb and see if it flashes. If it flashes, you need the emulators. If it does not, it is prob the flasher. Do this test with the bike running.

They ended up working once the battery charged up after some long distance 5th gear crusing, I found this out after it locked up in 5th gear about 60 miles an hour. I know a lot of people have had trans issues, the motor still runs. About how much have you guys put into these to get them back up to par after a trans failure. I just dumped 1000$ into this bike, paid 1000$ for it. I want to part it, i want to fix it and in some ways i want it to disappear.

I know a lot of people have had trans issues, the motor still runs. About how much have you guys put into these to get them back up to par after a trans failure.

Tranny failures are few and far between. I had over 13K on my 06 with tons and tons of baja/dual sport rides and I never had an issue. Same goes for my dad's 06 and a bunch of other WR owners that I know

Your looking close to 3-400 bucks for parts

If you want it to dissapear PM a price/picture and we'll see what we can do.

Well I have the thing stripped down. Waiting on a flywheel puller and I will split the cases. Then I will go from there. I really dont want to lose a bunch of money parting this thing out. But at the same time I want to get everything powdercoated black and put it on the street for good. I am worried about this happening again however.

I am worried about this happening again however.

Upgrade to the 04 parts like PDB said and you wont have to worry :thumbsup:

Thats what I want to hear. I will probably be starting a build thread with lots of pictures so look for that if you all want to keep up to date on this. Thanks for the info.

where are you at in ohio?

about 15mins south of Akron.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now