HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
Krannie McKranface

No electrics. Fuses not blown.

8 posts in this topic

Bike died while idling at a light. No electrics working; two fuses at relay not blown.

Any suggestions?

can you be a little more specific ?

battery dead ?

no ign power, LED dead ?? check for spark when kicking ???

sound like battery dead, and the stator is dead.. if fuse's are all good.

but not enought information.

Share this post


Link to post
Share on other sites

Is this the dual sported bike? All lighting running from the battery?

Share this post


Link to post
Share on other sites

FOUND IT.

One fuse was blown , but not across the wire, inside the post.

Need to get a second meter for the garage (not just the work van....)

Still need to find the intermittent short though...........................

Share this post


Link to post
Share on other sites
Are you sure you didn't forget to turn the gas on?:banana::worthy::banana: :banana:

I think the gas was on too long...................brain fumes!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0